Configure Cisco 877 as bridge between Internet and Cisco ASA 5505

5,954

Here's the config I used, and it worked:

no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
!
dot11 syslog
ip source-route
no ip routing
!
no ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
archive
 log config
  hidekeys
!
interface ATM0
 no ip address
 no ip route-cache
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5snap
 !
 bridge-group 1
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 no ip address
 no ip route-cache
 bridge-group 1
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
control-plane
!
bridge 1 protocol ieee
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login
!
scheduler max-task-time 5000
end

Source was Cisco DSL Router Configuration and Troubleshooting Guide - Cisco DSL Router: PC Acting as a PPPoE Client which needed adjusting slightly for the 877.

Share:
5,954

Related videos on Youtube

dunxd
Author by

dunxd

I'm currently freelance specialising in international connectivity and infrastructure working with clients in the humanitarian space. If your organisation struggles to work effectively because of limited internet options in far flung locations, maybe I can help. Until 2017 I worked at a large international development charity in London, as International Operations Manager. I managed a team of Regional ICT Service Managers, based in developing world countries, who kept the users happy through fixing problems, setting up great connectivity and generally making sure users could do their day jobs. I think I did a good job as a manager - some of my team went on to great things! I previously worked at the same place as International Network Systems Analyst. I looked after a bunch of ICT systems in offices in the developing world, as well as looking after systems in our HQ. I gained a lot of knowledge in that job, and the techy side competes with the people stuff in the new role, hence I still hang out here a lot. I'm passionate about the use of ICT in developing countries, both in terms of dealing with the inherent problems for ICT in those places, and using ICT as a tool for development.

Updated on September 18, 2022

Comments

  • dunxd
    dunxd over 1 year

    ISP ADSL ---- Cisco 877 Router ---- Cisco ASA 5505

    I have the above connection. I'd like to avoid using NAT on the Cisco 837 router, and just put the ASA directly on the Internet. However, I have to use the 837 to connect to the ISP - the ASA doesn't have an ADSL interface.

    I know how to configure the ASA to handle the pppoe connection, but not how to configure the 837 to act as a bridge between ADSL and Ethernet.

    Is this what is called RFC1483 bridging?

    Will the following config allow the ASA to do all the pppoe negotiation, and leave the 877 doing nothing more than bridging ethernet and ADSL?:

    no ip routing
    
    interface Ethernet0 
      no ip address
      no ip directed-broadcast   
      bridge-group 1
    
    encapsulation aal5snap
    
    bridge-group 1
    
    bridge 1 protocol ieee
    

    Unfortunately, this is our only site with an 800 series router connecting to the internet, so I am not very familiar with it, and I won't be able to test the configuration out properly until I get there.