Cisco dual static default routes to WAN

8,435

In this case, you can using route-map, create a policy for groups of clients. Some thing like this:

Define ACL:

ip access-list extended FirstLink
permit tcp 10.1.1.10 any eq www
deny ip any any

Define route map:

route-map FirstLan permit 10
match ip address FirstLink
set interface Fa0/0

Apply it to LAN interface:

interface FastEthernet1/0
description LAN
ip policy route-map FirstLan

But this requires you have another LAN interface to (Fa1/1) to make others hosts to go through.

For truly Load Balancing in this case, you can use pfr/OER

Share:
8,435

Related videos on Youtube

John Zoulias
Author by

John Zoulias

Updated on September 18, 2022

Comments

  • John Zoulias
    John Zoulias over 1 year

    I am trying to setup Dual WAN in our office because our single VDSL modem couldnt handle our web traffic any longer. So we now have two VDSL modems (Sagecom FAST2864) they cant go into bridge mode because they are locked down by our ISP. So I have to settle for disabling DHCP and WIFI on them and setting a static address on my cisco router.

    My topology looks like this ....

    enter image description here

    My issue is when both links are active and you try to browse the internet it takes 3 or 4 page refreshes before all the content loads. When I disable one of the links everything works fine! I have tried with both ip load-sharing per-packetand ip load-sharing per-destination both result in the exact same issue. I have posted my config below any direction on this issue would be very helpful as I am currently paying for a extra VDSL connection that is sitting unused.

    !
    hostname HWY404
    !
    !
    memory-size iomem 10
    ip subnet-zero
    ip cef
    !
    !
    ip name-server 8.8.8.8
    ip dhcp excluded-address 10.1.1.1 10.1.1.100
    !
    ip dhcp pool COMPUTERS
       network 10.1.1.0 255.255.255.0
       default-router 10.1.1.1
       dns-server 10.1.1.1
    !
    <!--OUTPUT OMITTED-->
    !
    interface ATM0/0
     no ip address
     shutdown
     no atm ilmi-keepalive
     dsl operating-mode auto
    !
    interface FastEthernet0/0
     description BELL-1
     ip address 192.168.2.200 255.255.255.0
     ip nat outside
     ip load-sharing per-packet
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     description BELL-2
     ip address 192.168.1.200 255.255.255.0
     ip nat outside
     ip load-sharing per-packet
     shutdown
     duplex auto
     speed auto
    !
    interface FastEthernet1/0
     description LOCAL LAN
     ip address 10.1.1.1 255.255.255.0
     ip nat inside
     ip load-sharing per-packet
     duplex auto
     speed auto
    !
    ip nat inside source route-map BELL1 interface FastEthernet0/0 overload
    ip nat inside source route-map BELL2 interface FastEthernet0/1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.2.1
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    ip http server
    ip pim bidir-enable
    !
    !
    !
    route-map BELL2 permit 10
     match interface FastEthernet0/1
    !
    route-map BELL1 permit 10
     match interface FastEthernet0/0
    !
    <!--OUTPUT OMITTED-->
    !
    end
    
  • John Zoulias
    John Zoulias over 10 years
    Will PFR/OER solve the HTTP session issues?
  • cuonglm
    cuonglm over 10 years
    From this doc: http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and‌​_MAN/Transport_diver‌​sity/PfR_Master_Cont‌​roller_Redundancy.ht‌​ml I think the answer is yes.