cisco ip nat / port forwarding

6,511

You mixed up source and destination in Port forwarding.

ip nat inside source static udp  interface FastEthernet0/0 9987 10.10.250.201 9987 extendable
ip nat inside source static tcp  interface FastEthernet0/0 30033 10.10.250.201 30033 extendable
ip nat inside source static tcp  interface FastEthernet0/0 10011 10.10.250.201 10011 extendable
ip nat inside source static tcp  interface FastEthernet0/0 443 10.10.250.201 22 extendable
ip nat inside source static tcp  interface FastEthernet0/0 80 10.10.250.201 80 extendable

Also use standard access list to allow only local networks to go through NAT.

ip access-list standard NAT
 permit ip 10.10.250.0 0.0.0.255
Share:
6,511

Related videos on Youtube

h3rrmiller
Author by

h3rrmiller

Network Security Engineer

Updated on September 18, 2022

Comments

  • h3rrmiller
    h3rrmiller over 1 year

    I have been trying to get port forwarding working with a newly installed cisco router. I cannot seem to find where my fault is and have been looking for quite a while.

    The relevant section of my config:

    interface FastEthernet0/0
     ip address dhcp
     ip nat outside
     speed 100
     full-duplex
     no cdp enable
    !
    interface FastEthernet0/1
     ip address 10.10.250.1 255.255.255.0
     ip nat inside
     speed 100
     full-duplex
    !
    router eigrp 250
     passive-interface FastEthernet0/0
     network 10.10.250.0 0.0.0.255
     no auto-summary
    !
    ip nat inside source list NAT interface FastEthernet0/0 overload
    ip nat inside source static udp 10.10.250.201 9987 interface FastEthernet0/0 9987
    ip nat inside source static tcp 10.10.250.201 30033 interface FastEthernet0/0 30033
    ip nat inside source static tcp 10.10.250.201 10011 interface FastEthernet0/0 10011
    ip nat inside source static tcp 10.10.250.201 22 interface FastEthernet0/0 443
    ip nat inside source static tcp 10.10.250.201 80 interface FastEthernet0/0 80
    no ip http server
    no ip http secure-server
    ip classless
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 dhcp
    !
    !
    !
    ip access-list extended NAT
     permit ip any any
    

    There has to be an issue with my config somewhere? Or am I missing something necessary to get port forwarding working?

    Here is the current NAT table stripped down to show only my rules:

    cisco2621#show ip nat tran
    Pro Inside global         Inside local          Outside local         Outside global
    udp x.x.x.x:9987    10.10.250.201:9987    ---                   ---
    tcp x.x.x.x:10011   10.10.250.201:10011   ---                   ---
    tcp x.x.x.x:80      10.10.250.201:80      ---                   ---
    tcp x.x.x.x:443     10.10.250.201:22      ---                   ---
    tcp x.x.x.x:30033   10.10.250.201:30033   ---                   ---
    
    • Admin
      Admin about 11 years
      from another friend. "I think it may be the access list. You are trying to forward TCP and UDP Ports but only have IP in the access list."
    • sartis
      sartis about 11 years
      can you add an output of show ip nat translations?
    • h3rrmiller
      h3rrmiller about 11 years
      @DukeLion Sorry for the delay, I was away. I updated the question to include the NAT table
    • Konrad Gajewski
      Konrad Gajewski almost 9 years
      Which router/IOS is it?