How can I configure my network to allow bi-directional traffic between two lans?

5,343

You seems to have issues with asymmetric routing and as in example B here: https://supportforums.cisco.com/docs/DOC-14491

Also, adding third interface with basic license may not help you as ASA5505 need separate license for DMZ or third VLAN. This is from Cisco:

Maximum Active VLAN Interfaces for Your License In routed mode, you can configure the following VLANs depending on your license:

  • Base license—3 active VLANs. The third VLAN can only be configured to initiate traffic to one other VLAN.
  • Security Plus license—20 active VLANs.

In transparent firewall mode, you can configure the following VLANs depending on your license: - Base license—2 active VLANs in 1 bridge group. - Security Plus license—3 active VLANs: 2 active VLANs in 1 bridge group, and 1 active VLAN for the failover link.

Solution:

  1. Get manageable network switches that can do static routing and route traffic through them;
  2. Get Security Plus license for ASA and connect network 192.168.41.0 to third VLAN, NAT it and all traffic will go though ASA. However, ASA 5505 has 100Mb interfaces and if you need to move large amount of data, solution 1 with manageable switches looks better.
Share:
5,343

Related videos on Youtube

Zach
Author by

Zach

Updated on September 18, 2022

Comments

  • Zach
    Zach over 1 year

    Here's my current setup: (and it may require reworking):

    • 2 LAN networks - 192.168.41.0, 192.168.21.0
    • 2 Public IP's (they are assigned to us by specifying MAC Addresses - not subnetted) 24.53.x.x, and the other is 192.34.x.x
    • Netgear Router
    • Linksys Router
    • ASA 5505 with base license

    I'll try to diagram the network the best I can for now. I'll improve it later when I have better access to tools. I've included my ASA Run config:

    • Cable modem -> Switch
    • Switch -> Netgear Router and ASA 5505 Netgear
    • Router hosts 192.168.41.0 network and is assigned one of the public IPs
    • ASA 5505 hosts 192.168.21.0 network and is assigned the other public IP
    • I connect switch behind each network (to the router and ASA) - so there are 3 total switches
    • In an attempt to join the two networks, I added a Linksys router to the switch behind the 21.0 network and assigned the router an address on the 21.0 network (192.168.21.254).
    • I then connected a line into the internet port on the Linksys router and assigned the wan an IP address on the 41.0 network (192.168.41.2).
    • On the 41.0 router (Netgear Router) I added a route to the 21.0 network via the 41.2 address
    • On the ASA for the 21.0 network, I added a route to the 41.0 network via the 21.254 address. I also added a couple ACL lines to permit traffic as well as same-security-intra-interface.

    Previously, I was able to get traffic to flow one way (21.0 can access 41.0 but not the other way around). I'm assuming it has something to do with either a problem in my structure logic or my nat logic. Currently, I can ping the 41.0 network from the 21.0 network but attempts to use other ports (like telnet the smtp server from port 25) fails. I'm hoping, with your support, we can start with what I have here and begin troubleshooting.

    ASA CONFIG

    : Saved
    :
    ASA Version 8.2(1)
    !
    hostname lilprecious
    domain-name mydomain.local
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd lVYsshR/yoydoM2/ encrypted
    no names
    name 192.168.21.10 precious_private
    name 192.168.21.1 asa_private
    name 192.34.x.56 precious_public
    !
    interface Vlan1
     nameif inside
     security-level 100
     ip address 192.168.21.1 255.255.255.0
    !
    interface Vlan2
     nameif outside
     security-level 0
     ip address 192.34.x.56 255.255.252.0
    !
    interface Ethernet0/0
    !
    interface Ethernet0/1
    !
    interface Ethernet0/2
    !
    interface Ethernet0/3
    !
    interface Ethernet0/4
    !
    interface Ethernet0/5
    !
    interface Ethernet0/6
    !
    interface Ethernet0/7
     switchport access vlan 2
    !
    ftp mode passive
    dns domain-lookup inside
    dns domain-lookup outside
    dns server-group DefaultDNS
     domain-name mydomain.local
    dns server-group PRECIOUS
     name-server 192.168.21.10
     domain-name mydomain.local
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group service exchange_server
     service-object icmp
     service-object tcp-udp eq www
     service-object tcp eq 587
     service-object tcp eq https
     service-object tcp eq smtp
    object-group service temp
     service-object tcp-udp eq 64092
    object-group service temp2
     service-object tcp-udp eq 59867
    access-list CASVPN_splitTunnelAcl standard permit 192.168.21.0 255.255.255.0
    access-list CASVPN_splitTunnelAcl standard permit 192.168.20.0 255.255.255.0
    access-list CASVPN_splitTunnelAcl standard permit 192.168.41.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.21.0 255.255.255.0 192.168.20.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.20.0 255.255.255.0 192.168.20.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.20.0 255.255.255.0 192.168.41.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.41.0 255.255.255.0 192.168.21.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.21.0 255.255.255.0 192.168.41.0 255.255.255.0
    access-list ping extended permit icmp any any echo-reply
    access-list ping extended permit tcp any host 192.34.x.56 eq www
    access-list ping extended permit object-group exchange_server any host 192.34.x.56
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool vpn_clients 192.168.20.100-192.168.20.199 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any inside
    icmp permit any outside
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface smtp 192.168.21.10 smtp netmask 255.255.255.255
    static (inside,outside) tcp interface www 192.168.21.10 www netmask 255.255.255.255
    static (inside,outside) tcp interface https 192.168.21.10 https netmask 255.255.255.255
    static (inside,outside) tcp interface 587 192.168.21.10 587 netmask 255.255.255.255
    access-group ping in interface outside
    route outside 0.0.0.0 0.0.0.0 192.34.xx.1 1
    route inside 192.168.41.0 255.255.255.0 192.168.21.254 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server Precious protocol ldap
    aaa-server Precious (inside) host 192.168.21.10
     timeout 5
     ldap-base-dn DC=mydomain,DC=local
     ldap-scope subtree
     ldap-login-password *
     ldap-login-dn CN=aduser,CN=Users,DC=mydomain,DC=local
     server-type auto-detect
    http server enable
    http 192.168.21.0 255.255.255.0 inside
    http 192.168.20.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 5
     authentication pre-share
     encryption 3des
     hash sha
     group 2
     lifetime 86400
    crypto isakmp policy 10
     authentication pre-share
     encryption des
     hash sha
     group 2
     lifetime 86400
    telnet 192.168.21.0 255.255.255.0 inside
    telnet 192.168.20.0 255.255.255.0 inside
    telnet timeout 20
    ssh timeout 20
    console timeout 0
    management-access inside
    dhcpd auto_config outside
    !
    
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy CASVPN internal
    group-policy CASVPN attributes
     wins-server value 192.168.21.10
     dns-server value 192.168.21.10
     vpn-tunnel-protocol IPSec
     split-tunnel-policy tunnelspecified
     split-tunnel-network-list value CASVPN_splitTunnelAcl
     default-domain value mydomain.local
    tunnel-group CASVPN type remote-access
    tunnel-group CASVPN general-attributes
     address-pool vpn_clients
     authentication-server-group Precious
     default-group-policy CASVPN
    tunnel-group CASVPN ipsec-attributes
     pre-shared-key *
    !
    !
    prompt hostname context
    Cryptochecksum:3b181b87399ae99bb504d3cd42adc880
    : end
    
    • joeqwerty
      joeqwerty about 11 years
      What do you mean by this statement: "Public IP's (they are assigned to us by specifying MAC Addresses - not subnetted)"?
    • Zach
      Zach about 11 years
      Sorry. I knew that statement might cause confusion. Essentially, I'm used to bigger ISP's who allocate public IPs to you by creating a subnet with a range of IP addresses. For example, a public IP of 173.167.81.148 with subnet mask of 255.255.255.248 is on a 173.167.81.144 subnet with a default gateway IP and 5 available public IPs. Well this ISP instead reserves an IP address from its public IP pool and requires you tell them the MAC address of the interfaces which will be assigned the static IP address.
    • joeqwerty
      joeqwerty about 11 years
      Does the Netgear router and the ASA have a public ip address in the same subnet?
    • Zach
      Zach about 11 years
      No. One is 24.53.x.x, and the other is 192.34.x.x
    • Zach
      Zach about 11 years
      Interesting idea! I know I can access the 41.x's public ip from 21.x. I'll try that.
    • Zach
      Zach about 11 years
      That's not an option for me I'm afraid. The tracert crosses networks.
  • cpt_fink
    cpt_fink about 11 years
    Can the base license on the 5505 have 3 interfaces talking to each other?
  • MikeAWood
    MikeAWood about 11 years
    I am not a Cisco tech, so not sure.. but this seems to indicate that you can have 3 vlans. (cisco.com/en/US/products/ps6120/prod_models_comparison.html‌​) It looks like maybe they intended the 3rd VLAN to be something like an (un)trusted DMZ, so I am not sure. Might be worth it to give creating another interface a shot and see if it works...
  • Zach
    Zach about 11 years
    You can with no forward, and I tried to do this last night but it didn't work initially. It states you only need to put no forward to one vlan which I figured I'd forward it VLAN2 which is my internet. I wanted both lans to be able to initiate contact with each other. I'll admit I didn't really dive into the problem but here is another question that does that - serverfault.com/questions/151569/…
  • MikeAWood
    MikeAWood about 11 years
    I would assume (again, not being a cisco tech) that you wouldn't want no forward in your case if you want both vlans to be accessible from each other. Should be simple routing between the two VLANs. For my Netgear L3 switches, they call this VLAN Routing.
  • Zach
    Zach about 11 years
    Correct. I was hoping it meant that you sacrifice 1 VLAN forwarding, but that forwarding works to the other, since the limitation on the base license for having a third VLAN requires you apply a "No Forward" to ONE other VLAN. This didn't seem to be the case.
  • Zach
    Zach about 11 years
    I do have a manageable switch, but I'm considering another way to set things up. I'll get back to this in a couple days.