What's the easiest way to have a script run at boot time in OS X?

20,824

Solution 1

MacOS X uses Vixie cron, which has special meta tags for launching at reboot time. See the man page for the file format.

something like:

@reboot /path/to/script.sh

in your crontab would work. I'm not sure that this a better solution than launchd, you probably have more meta tools that look at launchd than cron.

Solution 2

In case you change your opinion:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Label</key>
    <string>com.superuser.245713</string>
    <key>ProgramArguments</key>
    <array>
        <string>/path/to/script.sh</string>
    </array>
    <key>UserName</key>
    <string>someuser</string>
</dict>
</plist>

Store as com.superuser.245713.plist in /Library/LaunchAgents/ and make root:wheel the owner/group.

Solution 3

There are also Login Hooks if you would prefer the script to run (as root) when a user logs in rather than when the machine is booted.

Here is an example which provides a briefer explanation about them: How to run a script at login/logout in OS X?

Share:
20,824

Related videos on Youtube

John Bachir
Author by

John Bachir

Formerly CTO at Freedom, Co-Founder &amp; CTO at Medstro.

Updated on September 17, 2022

Comments

  • John Bachir
    John Bachir almost 2 years

    I want a script (bash/zsh/ruby/...) to run at boot time in OS X. What's the most simple way to do this, without messing with xml/plist files, and preferably not needing to make a meta AppleScript.

  • HikeMike
    HikeMike over 13 years
    Love it, you proved me wrong :-) Although cron on OS X is not that great with logging by default (there was a topic on that just a few days ago).
  • Doug Harris
    Doug Harris over 13 years
    It's arguably better to put it into /Library/LaunchAgents rather than /System/Library/LaunchDaemons since /System is OS-specific stuff and the one under /Library is used more for third party stuff. Also, LaunchDaemons "should contain items that will run as root, generally background processes" where as LaunchAgents "run as a user or in the context of userland". The source for those quotes is a great article on launchd that I consult for launchd questions.
  • HikeMike
    HikeMike over 13 years
    @DougHarris Thanks for the suggestions! I have to admit I was just typing this ad-hoc -- while I usually test my solutions, I wasn't willing to restart my machine for this.
  • John Bachir
    John Bachir over 13 years
    this is perfect.
  • John Bachir
    John Bachir over 13 years
    This is very nice, although I like the Vixie cron solution better :)
  • Norman Gray
    Norman Gray over 13 years
    Note that cron, at, and so on are to some extent deprecated in OS X. I can't find an explicit statement of that in the various docs, nor do I know how aggressively deprecated they are, but launchd does seem generally preferred. See the launchd documentation for an introduction.
  • Gordon Davisson
    Gordon Davisson about 12 years
    Actually, it should be put in /Library/LaunchDaemons. Agents only run inside a user session, i.e. they won't run (or more precisely, become eligible to run) until someone logs in, will run again every time someone logs in, and always run as the currently logged in user. Daemons run (/become eligible to run) at boot, and while they normally run as root, can be run as some other user with the UserName key.
  • HikeMike
    HikeMike over 10 years
  • BGBRUNO
    BGBRUNO over 8 years
    plist won't work for me - this works like a charm - thank you! :-D
  • NobleUplift
    NobleUplift over 5 years
    Honestly wasn't sure if the syntax would be the same on OS X.